Back to overview
Resolved
Platform down
Jun 4, 2026 at 10:20am UTC
Affected services
app.emma.legal
Resolved
Jun 4, 2026 at 10:20am UTC
The Emma platform is currently experiencing down time.
Affected services
Resolved
Jun 4, 2026 at 10:20am UTC
The Emma platform is currently experiencing down time.
Affected services