Back to overview
Resolved
Back operational
Jun 4, 2026 at 10:53am UTC
Affected services
app.emma.legal
Resolved
Jun 4, 2026 at 10:53am UTC
The platform is back up and running and we will keep monitoring the situation
Affected services