Back to overview
Resolved
Degraded performance
Jun 22, 2026 at 8:16am UTC
Affected services
app.emma.legal
Resolved
Jun 23, 2026 at 12:57pm UTC
AI operations are operating as normal again. We are monitoring the situation closely.
Affected services
Updated
Jun 23, 2026 at 10:56am UTC
AI processing pipelines are running slower than expected.
Affected services
Updated
Jun 22, 2026 at 9:00am UTC
Back operational. We are monitoring the systems closely.
Affected services
Created
Jun 22, 2026 at 8:16am UTC
The Emma platform is encountering degraded performance and can be really slow load for some users
Affected services